import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((1*),\\3)|((1*),((\\5)1+))|((1*),((?!\\9)1+)))$";
final String string = "111111,11111";
final String subst = "$2|$5,$6|$9,$10";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}