const regex = /^(((1*),\3)|((1*),((\5)1+))|((1*),((?!\9)1+)))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((1*),\\3)|((1*),((\\5)1+))|((1*),((?!\\9)1+)))$', '')
const str = `111111,11111`;
const subst = `$2|$5,$6|$9,$10`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);