$re = '/^(((1*),\3)|((1*),((\5)1+))|((1*),((?!\9)1+)))$/';
$str = '111111,11111';
$subst = "$2|$5,$6|$9,$10";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;