// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\((.+)\)$").unwrap();
let string = "Happy Day Care Club (1124734)
French Pattiserie (8985D)
The King's Pantry (G6666642742D)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}