using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?href=\""(.+?.pdf\?min)\"".*?>(.*?)<\/a>";
string substitution = @"ok";
string input = @"<table cellspacing=""0"" cellpadding=""0"" width=""100%"" border=""0"">
<tbody>
<tr>
<td width=""25%""><a href=""http://www.test.com/myfile.pdf?min"" target=""_blank"">Menus 18 €</a></div></td>
<td width=""25%""><a href=""http://www.test.com/myfile.pdf?min"" target=""_blank"">Menus 24 et 26 €</a></div></td>
<td width=""25%""><a href=""http://www.test.com/myfile.pdf?min"" target=""_blank"">Menus 30 et 37 € </a></div></td>
<td width=""25%""><a href=""http://www.test.com/myfile.pdf?min"">La Carte détaillée <br>
(Entrées - Viandes - Poissons)</a></td>
</tr>
</tbody>
</table>";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}