// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<a.*?href=\"(.+?.pdf\?min)\".*?>(.*?)<\/a>"#).unwrap();
let string = "<table cellspacing=\"0\" cellpadding=\"0\" width=\"100%\" border=\"0\">
<tbody>
<tr>
<td width=\"25%\"><a href=\"http://www.test.com/myfile.pdf?min\" target=\"_blank\">Menus 18 €</a></div></td>
<td width=\"25%\"><a href=\"http://www.test.com/myfile.pdf?min\" target=\"_blank\">Menus 24 et 26 €</a></div></td>
<td width=\"25%\"><a href=\"http://www.test.com/myfile.pdf?min\" target=\"_blank\">Menus 30 et 37 € </a></div></td>
<td width=\"25%\"><a href=\"http://www.test.com/myfile.pdf?min\">La Carte détaillée <br>
(Entrées - Viandes - Poissons)</a></td>
</tr>
</tbody>
</table>";
let substitution = "ok";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}