import Foundation
let pattern = #"<a.*?href=\"(.+?.pdf\?min)\".*?>(.*?)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<table cellspacing="0" cellpadding="0" width="100%" border="0">
<tbody>
<tr>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min" target="_blank">Menus 18 €</a></div></td>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min" target="_blank">Menus 24 et 26 €</a></div></td>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min" target="_blank">Menus 30 et 37 € </a></div></td>
<td width="25%"><a href="http://www.test.com/myfile.pdf?min">La Carte détaillée <br>
(Entrées - Viandes - Poissons)</a></td>
</tr>
</tbody>
</table>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"ok"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)