$re = '/0([123]+(?:{[^}]*}[123]*)*)0/m';
$str = '0213123123130
012312312312303123123
01231230123123031230
01213123123123{21310030123012301}31231230123
01212121{hello 0}121312
012321212211231{whatever 3 gArBaGe? I want.}1212313123120123
012321212211231{whatever 3 gArBaGe? I want.}121231{extra garbage}3123120123';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;