using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<number>)(?:\s*<number>)+";
string substitution = @"\1";
string input = @"""<number> <number>"" -> ""<number>""
""<number><number>""-> ""<number>""
but not
""<number> test <number>"" -> ""<number> test <number>""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}