$re = '/(<number>)(?:\s*<number>)+/m';
$str = '"<number> <number>" -> "<number>"
"<number><number>"-> "<number>"
but not
"<number> test <number>" -> "<number> test <number>"';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;