re = /(<number>)(?:\s*<number>)+/m
str = '"<number> <number>" -> "<number>"
"<number><number>"-> "<number>"
but not
"<number> test <number>" -> "<number> test <number>"'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result