Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(\bByVal\b|\bByRef\b)? +(\w+)(?: +as +(\w+))?(?: *= *[\w"]+)? *[\)|,]?
/
i
Input 1
1
New
ByVal S_Random, ByVal S_Sign_JS, ByRef S_Ksc, ByRef HS_EkscEkakscn, ByRef intResult, ByVal strEKA, ByVal strNmLogon, ByVal StrNivelUsuario, ByVal lngIDConexao, ByVal strBanco, ByVal strAgencia, ByVal strConta, ByVal strTipoDePessoa, ByVal lngCodUsuario, ByVal lngContrato, ByRef LngRetCode, ByRef strErro, ByRef strErroTecnica, ByVal intIdCanal, ByVal strIPAddrCliente, ByVal strIPAddrServer, Optional ByRef S_PW, Optional ByRef S_PBE