#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:<[^>]*>|&[^; ]*;)(*SKIP)(*F)|micro"
Local $sString = "<test><micro>" & @CRLF & _
"micro" & @CRLF & _
"&test;micro" & @CRLF & _
"test micro" & @CRLF & _
"test <test> test <test>micro" & @CRLF & _
"test<te> micro" & @CRLF & _
"test<te> test micro" & @CRLF & _
"&test;abcmicro" & @CRLF & _
"<a><b>micro" & @CRLF & _
"<a><b>ab <>micro" & @CRLF & _
"&test;micro&test;micro&test;&test;<ab><test>micro&test;&test;test micro"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")