// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:<[^>]*>|&[^; ]*;)(*SKIP)(*F)|micro").unwrap();
let string = "<test><micro>
micro
&test;micro
test micro
test <test> test <test>micro
test<te> micro
test<te> test micro
&test;abcmicro
<a><b>micro
<a><b>ab <>micro
&test;micro&test;micro&test;&test;<ab><test>micro&test;&test;test micro";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}