import Foundation
let pattern = #"(?:<[^>]*>|&[^; ]*;)(*SKIP)(*F)|micro"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<test><micro>
micro
&test;micro
test micro
test <test> test <test>micro
test<te> micro
test<te> test micro
&test;abcmicro
<a><b>micro
<a><b>ab <>micro
&test;micro&test;micro&test;&test;<ab><test>micro&test;&test;test micro
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)