package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\w+\(([^)]+)\)|\w+\(()\))\p{Zs}*{`)
var str = `public string Foo(string i1, int i2, string Cad_demo){
var demo = string.Empty;
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}