const regex = /(?:\w+\(([^)]+)\)|\w+\(()\))\p{Zs}*{/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\w+\\(([^)]+)\\)|\\w+\\(()\\))\\p{Zs}*{', '')
const str = `public string Foo(string i1, int i2, string Cad_demo){
var demo = string.Empty;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}