using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"line vty 0 4.*\n(.*\n)*.*exec-timeout 29 0";
string input = @"line con 0
exec-timeout 29 0
line vty 0 4
privilege level 15
password 7 053B071B701F401D5D0346004F18
logging synchronous
transport input ssh
25478
exec-timeout 29 0
12345
23456
314564
clock timezone EST -5 0
clock summer-time EST 2 Sun Mar 02:00 1 Sun Nov 02:00 60
cli alias name wr copy running-config startup-config
line console
line vty";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}