use strict;
my $str = '"members": [
{
"id": "0",
"username": "User1",
"discriminator": "0000",
"avatar": null,
"status": "online",
"avatar_url": "https://cdn.discordapp.com/widget-avatars/...",
"deaf": false,
"mute": false,
"self_deaf": false,
"self_mute": false,
"suppress": false,
"channel_id": "42"
},
{
"id": "1",
"username": "Bot1",
"discriminator": "0000",
"avatar": null,
"status": "online",
"avatar_url": "https://cdn.discordapp.com/widget-avatars/..."
},
{
"id": "2",
"username": "Bot2",
"discriminator": "0000",
"avatar": null,
"status": "online",
"avatar_url": "https://cdn.discordapp.com/widget-avatars/...",
"game": {
"name": "music | /help"
},
"deaf": false,
"mute": false,
"self_deaf": false,
"self_mute": false,
"suppress": false,
"channel_id": "17"
}
],
"presence_count": 3
}';
my $regex = qr/"username": "(?!Bot[12]")([^"]+)",(?:\s*"[^"]+": (?:[^"]+|"[^"]*"),)*\s*"channel_id": "(\d+)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}