using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\/(\w+)(?:\+(\w+))?(?:\s?;\s?([\w-]+)=([\w!:\$\.-]+))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?(?:\s?;\s?((?4))=((?5)))?";
string input = @"application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello
application/xhtml+json; q=1000; level=4 ; w=40";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}