// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+):\s+(.*)\r?\n").unwrap();
let string = "/*
title: Introduction
*/
Introduction
============
[This is a link](http://google.com)

* This is a list
* This is a list
* [This is a link](http://google.com)
* ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}