$re = '/<span question_number="(\d+)">(.*?)<\/span>/';
$str = '<span question_number="54">often graces doorways tied into ropes called</span>
<span question_number="55">Allow retracting flags on deleted posts even if you can\'t view deleted posts</span>
<span question_number="56">Multiple accepted answer to a question?</span><span question_number="57">Post-edit by 3rd party editor created errors, and 3 out of 4 editors approved</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);