using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^DT(\s+DT)*((\s+RB)+|(\s+JJ)+)(\s+NN)+$";
string input = @"DT NN IN NN
DT RB JJ NN
DT JJ JJ NN
DT RB RB NN NN
DT RB RB";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}