use strict;
my $str = '"خيار",
"بصل",
"طماطم",
"سكّر",
"علبة ملح",
"طبق بيض",
"قميص",
"قمصان",
"ثوب",
"أثواب",
"معجم",
"دفتر",
"قلم",
';
my $regex = qr/"|,/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";