$re = '/(\d)(?=9*.[\d:]{6}1\d*~\d*?\1(\d))|:.*/';
$str = '511810:011011~01234567890';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;