const regex = /\b(?:Bs|Usd)\b.*?(?=\s*Cuenta\b|$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:Bs|Usd)\\b.*?(?=\\s*Cuenta\\b|$)', 'gmi')
const str = `Cuenta de Ahorros | 1231231231 Bs 102,423.88 Cuenta de Ahorros | 1231233123 Usd 102,423.88 Cuenta de Ahorros | 87316633 Usd 10.233 Cuenta de Ahorros | 49189387113313 Usd 12.301`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}