#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0[1-9]|1[0-2])(\/|-)([0-9]{4})$"
Local $sString = "02/2413" & @CRLF & _
"11/2011" & @CRLF & _
"01/2015" & @CRLF & _
"02/2013" & @CRLF & _
"12/2014" & @CRLF & _
"02/2013" & @CRLF & _
"01-2013" & @CRLF & _
"02/2013" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")