$re = '/^(0[1-9]|1[0-2])(\/|-)([0-9]{4})$/m';
$str = '02/2413
11/2011
01/2015
02/2013
12/2014
02/2013
01-2013
02/2013
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);