// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?us)<div class="container">(.+?)\n<\/div>"#).unwrap();
let string = "<div class=\"container\">
<div class=\"box\">
..... (some code)
</div>
<div class=\"box\">
..... (some code)
</div>
<div class=\"box\">
..... (some code)
</div>
<div class=\"box\">
..... (some code)
</div>
</div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}