import Foundation
let pattern = ##"^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[~@#%=^*\-_+\[{}\]:./?!])(?!.*(.)(\1\1))[\w~@#%=^*\-_+\[{}\]:./?!]{8,64}$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Password_pass
PASSWORD_123
Password123
Password_123
Password_123
Password_1233
Password_12333
Password__123
Password___123
Password#123
Password~123
Password?[]123
Pa_1234
Pa_12345
Pa_0123456789012345678901234567890123456789012345678901234567890
Pa_01234567890123456789012345678901234567890123456789012345678901
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)