#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?:\/\/(dev|www).pricewombat.com\/d\/[^ \n]+)$"
Local $sString = "this is a test yo " & @CRLF & _
"test regexbuddy.com" & @CRLF & _
"www.regexbuddy.com" & @CRLF & _
"http://regexbuddy.com cvc" & @CRLF & _
"http://www.regexbuddy.com cvcv" & @CRLF & _
"http://www.regexbuddy.com/ g" & @CRLF & _
"http://www.regexbuddy.com/index.html f" & @CRLF & _
"http://www.regexbuddy.com/index.html?source=library f" & @CRLF & _
"You can download RegexBu ddy at http://www.regexbuddy.com/download.html. f" & @CRLF & _
""www.domain.com/quoted URL with spaces"" & @CRLF & _
"http://10.2.2.1.2/ttxx/txt/gg v" & @CRLF & _
"support@regexbuddy.com" & @CRLF & _
"" & @CRLF & _
"http://dev.pricewombat.com/d/4" & @CRLF & _
"http://www.pricewombat.com/d/12/Spalding-Premier-Excel-Basketball-15-Free-Store-Pickup"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")