$re = '/([+-]?[0-9]*\.[0-9]*)/';
$str = '123123132 , 05/03/1994 , +1.06697, -1.06697, 1.06697
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);