// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([+-]?[0-9]*\.[0-9]*)").unwrap();
let string = "123123132 , 05/03/1994 , +1.06697, -1.06697, 1.06697
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}