# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((([A-Za-z][A-Za-z0-9]*[\.\_]*[A-Za-z0-9]+){0,30}@[a-z]{3,15}\.[a-z]{2,5})|(([A-Za-z][A-Za-z0-9]*[._]*[A-Za-z0-9]+){0,30}@[a-z]{3,15}\.[a-z]{2}\.[a-z]{2,5}))$//;t' <<< "lkffdsl@gmail.co.co"