import re
regex = re.compile(r"\"([A-Z0-9-_]*\/[A-Z0-9-_]*)\":\s\"([\,<>=-~*.@A-Z0-9]*)\"", flags=re.IGNORECASE)
test_str = ("\"silex/silex\": \"*\",\n"
"\"pomm/pomm-service-provider\": \"*@dev\",\n"
"\"twig/twig\": \"*\",\n"
"\"symfony/yaml\": \"~2.6\",\n"
" \"incenteev/composer-parameter-handler\": \"~2.1\",\n"
" \"sanpi/twitter-bootstrap-installer\": \"~1.1\"\n"
" \"silex/web-profiler\": \"*\",\n"
" \"atoum/atoum\": \"~1.0\",\n"
" \"behatch/contexts\": \"~2.0\",\n"
" \"behat/mink-extension\": \"~2.0\",\n"
" \"behat/mink-goutte-driver\": \"*\"")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")