re = /"([A-Z0-9-_]*\/[A-Z0-9-_]*)":\s"([\,<>=-~*.@A-Z0-9]*)"/i
str = '"silex/silex": "*",
"pomm/pomm-service-provider": "*@dev",
"twig/twig": "*",
"symfony/yaml": "~2.6",
"incenteev/composer-parameter-handler": "~2.1",
"sanpi/twitter-bootstrap-installer": "~1.1"
"silex/web-profiler": "*",
"atoum/atoum": "~1.0",
"behatch/contexts": "~2.0",
"behat/mink-extension": "~2.0",
"behat/mink-goutte-driver": "*"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end