package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\(|\b)[\w]{3}\s*\)?[.-]?\s*[\w]{3}\s*[.-]\s*[\w]{3,4}\b`)
var str = `xxx.xxx.xxx
xxx-xxx-xxx
(xxx)xxx-xxxx
(xxx) xxx-xxxx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}