using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/.+\/b2citmdsp\.pgm[^=]+=(.*)";
string substitution = @"http://www.newdomain.com/prodpage.pgm?item=\1";
string input = @"http://www.olddomain.com/b2c/b2citmdsp.pgm?pp_skmno=18297
http://www.olddomain.com/b2c/blablabla.pgm?pp_skmno=18297";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}