#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<day>0[1-9]|[12]\d|3[01])(?P<seperator>[\/-])(?P<month>0[1-9]|1[012])(?P=seperator)(?P<year>\d\d\d\d)"
Local $sString = "12/02/2134" & @CRLF & _
"" & @CRLF & _
"00/02/2134" & @CRLF & _
"" & @CRLF & _
"01/02/2134" & @CRLF & _
"" & @CRLF & _
"31-12-2134" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"31-12/2134" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")