package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?|(\w+\s*:)\s*(\W\d+)|(\W\d+))`)
var str = `price: $200
$200`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}