#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.*[_G-Z])\w\w([:-]?)(?:\w\w\1){6}\w\w$"
Local $sString = "00:13:a2:00:41:8b:93:7a" & @CRLF & _
"0013a200418b937a" & @CRLF & _
"AD:12:13:FC:14:EE:FF:FF" & @CRLF & _
"ad-12-13-fc-14-ee-ff-ad" & @CRLF & _
"ad-12-13-fc:14-ee-ff-ad" & @CRLF & _
"ad-12-13-fc14-ee-ff-ad" & @CRLF & _
"0013a200418b:937a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")