#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?:\s*\* \N+\n)+)"
Local $sString = " * Some text in a bullet list." & @CRLF & _
" * Some more text in the same bullet list" & @CRLF & _
"" & @CRLF & _
"Break my pattern with a random number of normal text." & @CRLF & _
"That keeps going for some time" & @CRLF & _
"" & @CRLF & _
" * Back to some text in a bullet list" & @CRLF & _
" * That goes on" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")