// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^(?:\s*\* \N+\n)+)").unwrap();
let string = " * Some text in a bullet list.
* Some more text in the same bullet list
Break my pattern with a random number of normal text.
That keeps going for some time
* Back to some text in a bullet list
* That goes on
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}