use strict;
my $str = '<img src="../imgTest.jpg" alt="Something "quoted here, or here"">';
my $regex = qr/(=\s*"[^=">]*)"([^=">]*)"([^=">]*")/p;
my $subst = '$1\'$2\'$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";