$re = '/(=\s*"[^=">]*)"([^=">]*)"([^=">]*")/';
$str = '<img src="../imgTest.jpg" alt="Something "quoted here, or here"">';
$subst = "$1'$2'$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;