# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^0+\..+?\K|0+$//gm;t' <<< "0010.003000
100.000
000.2000
0.0000"