#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^0+\..+?\K|0+$"
Local $sString = "0010.003000" & @CRLF & _
"100.000" & @CRLF & _
"000.2000" & @CRLF & _
"0.0000"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)