use strict;
my $str = '0010.003000
100.000
000.2000
0.0000';
my $regex = qr/^0+\..+?\K|0+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";