import Foundation
let pattern = #"(\d{4}\.\dg).+(\d\d:\d\d:\d\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1967.0g 12:03:42"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}