// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a href="">(.*?)<\/a>"#).unwrap();
let string = "<a href=\"\">xxx</a>
<a href=\"\">yyy</a>
<a href=\"\">zzz</a>";
let substitution = "<a href=\"$1\">$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}